HTTPS error 403 for rhel-7-server-rpms

Latest response

Since 2020-08-24, trying to install RPMs on a RHEL system fails with HTTPS error 403:

https://cdn.redhat.com/content/dist/rhel/server/7/7Server/x86_64/os/repodata/repomd.xml: [Errno 14] HTTPS Error 403 - Forbidden
Trying other mirror.
To address this issue please refer to the below knowledge base article
https://access.redhat.com/solutions/69319
If above article doesn't help to resolve this issue please open a ticket with Red Hat Support.

This is an automated test that installs an RPM we build on a minimally installed RHEL system, and the error above comes when it tries to install dependencies.

Interestingly enough, this seems to be to the day a year after the snapshot install was created (2019-08-23), is there something that would only be enabled for a year?

We revert the VM between each call, but reinitialize subscription-manager before trying to install the RPM:

subscription-manager refresh
subscription-manager status
subscription-manager attach --auto

This outputs an all clear message, but claims there is a network error:

Network error. Please check the connection details, or see /var/log/rhsm/rhsm.log for more information.
+-------------------------------------------+
System Status Details
+-------------------------------------------+
Overall Status: Current

All installed products are covered by valid entitlements. No need to update > subscriptions at this time.

Installed Product Current Status:
Product Name: Red Hat Enterprise Linux Server
Status: Subscribed

Network error. Please check the connection details, or see /var/log/rhsm/rhsm.log for more information.
Network error. Please check the connection details, or see /var/log/rhsm/rhsm.log for more information.

The error messages gives me the advice to disable the rhel-7-server-rpms repo, which would make it difficult to install anything:

 4. Disable the repository permanently, so yum won't use it by default. Yum
   will then just ignore the repository until you permanently enable it
   again or use --enablerepo for temporary usage:

       yum-config-manager --disable rhel-7-server-rpms
   or
       subscription-manager repos --disable=rhel-7-server-rpms

Responses

Hi Peter,

As you say the problem exists since four days, I recommend to contact the Red Hat Customer Service team. :)

Regards,
Christian