Unexpected EOF error when pulling from Redhat registry

Latest response

Hi,

currently I am not able to pull this the jenkins-ose image from registry.redhat.io.

❯ docker login registry.redhat.io
Authenticating with existing credentials...
Login Succeeded
❯ docker pull registry.redhat.io/openshift4/ose-jenkins
Using default tag: latest
latest: Pulling from openshift4/ose-jenkins
a3ac36470b00: Already exists 
82a8f4ea76cb: Already exists 
d094068878fd: Already exists 
731fd7e5a973: Already exists 
6167c247dc6d: Already exists 
8aef7111d909: Downloading [==================================================>]  368.9MB/368.9MB
unexpected EOF

I tried to pull it from my local PC and a separate Openshift installation.
I also tried the version tags 'latest', '4.4' and '4.3'. The error still persists. Other images from the same repo can be downloaded.

Any suggestions on how to resolve this issue? Thanks in advance.

Responses

Are you having issues with any other images or just the one you specify?

Just this one

Is the image listed when you do a 'docker images' or is it missing? If it's there, can you do a 'docker rmi 8aef7111d909' and then try the pull again?

I am getting this problem too.

docker pull registry.redhat.io/openshift3/ose-logging-elasticsearch5:v3.11.43 Trying to pull repository registry.redhat.io/openshift3/ose-logging-elasticsearch5 ... v3.11.43: Pulling from registry.redhat.io/openshift3/ose-logging-elasticsearch5 9a1bea865f79: Already exists 602125c154e3: Already exists 236b0cd26d3b: Downloading [=> ] 4.833 MB/128.7 MB 236b0cd26d3b: Downloading [==================================================>] 122.4 MB/122.4 MB

unexpected EOF

A customer reports the same problem to me but with other images!

I tried using podman but got the same problem

podman pull registry.redhat.io/openshift3/ose-logging-elasticsearch5:v3.11.43 Trying to pull registry.redhat.io/openshift3/ose-logging-elasticsearch5:v3.11.43...Getting image source signatures Copying blob 9a1bea865f79: 72.21 MiB / 72.21 MiB [==========================] 9s Copying blob 602125c154e3: 1.21 KiB / 1.21 KiB [============================] 9s Copying blob 236b0cd26d3b: 40.00 MiB / 152.72 MiB [======>------------------] 9s Copying blob 656510d5e58e: 47.59 MiB / 47.59 MiB [==========================] 9s Failed error pulling image "registry.redhat.io/openshift3/ose-logging-elasticsearch5:v3.11.43": unable to pull registry.redhat.io/openshift3/ose-logging-elasticsearch5:v3.11.43: unable to pull image: Error writing blob: error storing blob to file "/var/tmp/storage451417384/2": unexpected EOF

Having a similar issue while installing Ansible Tower on OCP 4.3

Failed to pull image "registry.redhat.io/ansible-tower-37/ansible-tower-rhel7:3.7.1": rpc error: code = Unknown desc = Error writing blob: error storing blob to file "/var/tmp/storage048614969/3": unexpected EOF

Drew Douglas,

Not yet for now...

you can see the status on https://status.redhat.com/

This should be resolved... Looks like it was CDN related.

Yes, it works now. Thanks for your support!