yum -x 'kernel*' update --skip-broken

Latest response

I am running Redhat 6.4 and doesn't want to update the kernel now due to some GPFS storage issues. I have

more /etc/yum.conf

[main]
exclude=kernel*

so did a yum update and it has given the following error.

---> Package irqbalance.x86_64 2:1.0.7-9.el6 will be an update
--> Processing Dependency: kernel >= 2.6.32-358.2.1 for package: 2:irqbalance-1.0.7-9.el6.x86_64
---> Package python-backports.x86_64 0:1.0-5.el6 will be installed
--> Finished Dependency Resolution
Error: Package: 2:irqbalance-1.0.7-9.el6.x86_64 (rhel-6-server-rpms)
Requires: kernel >= 2.6.32-358.2.1
Installed: kernel-2.6.32-358.el6.x86_64 (@anaconda-RedHatEnterpriseLinux-201301301459.x86_64/6.4)
kernel = 2.6.32-358.el6
kernel = 2.6.32-358.el6


yum can be configured to try to resolve such errors by temporarily enabling
disabled repos and searching for missing dependencies.
To enable this functionality please set 'notify_only=0' in /etc/yum/pluginconf.d/search-disabled-repos.conf


Error: Package: 2:irqbalance-1.0.7-9.el6.x86_64 (rhel-6-server-rpms)
Requires: kernel >= 2.6.32-358.2.1
Installed: kernel-2.6.32-358.el6.x86_64 (@anaconda-RedHatEnterpriseLinux-201301301459.x86_64/6.4)
kernel = 2.6.32-358.el6
kernel = 2.6.32-358.el6
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

====================================
so I did

yum -x 'kernel*' update --skip-broken

and it updated the kernel also to

cat /etc/issue

Red Hat Enterprise Linux Server release 6.10 (Santiago)

kindly advise why did it update the kernel?
I have another 14 machines to do the security update only excluding the kernel update.
how will i do that , kindly advise
thanks
Abraham

Responses

Hi Abraham,

I am a bit confused, you start the article that you run RHEL 6.4 and the output of cat /etc/issues show RHEL 6.10.

yum update --skip-broken ignores the /etc/yum.conf exclude lines, because you tell it to fix any broken dependencies it is able to solve.

It is better to stop the yum update when asking for advise, instead of continuing if this might cause issues with other software, like GPFS.

It a good practise to show the at least the command yum update kernel, if the output is very long show some of the starting lines with a remark I skipped some lines, and like you did show the errors.

Be aware this is a customer forum most of us are not Red Hat employees, so we can only give advises.

Red Hat support cases are bound by a SLA, our advises are not.

Regards,

Jan Gerrit

Thanks Jian - cat /etc/issues output (RHEL 6.10) was after the update - so this (yum -x 'kernel*' update --skip-broken ) will not skip the kernel update? - can i go back to RHEL 6.4?

/etc/issue (and /etc/redhat-release) does not necessarily reflect the kernel version - what does 'rpm -q kernel' show?

Hi Jian, thanks so much for your kind reply,

[root@ikm278l ~]# rpm -q kernel kernel-2.6.32-358.el6.x86_64 [root@ikm278l ~]# cd /boot [root@ikm278l boot]# ls -lrt init* -rw-r--r--. 1 root root 16862696 Jan 19 2016 initramfs-2.6.32-358.el6.x86_64.img -rw-r--r--. 1 root root 16931141 Jan 21 2016 initramfs-2.6.32-358.el6.x86_64_v1.img -rw-------. 1 root root 8289892 Jun 23 15:17 initrd-2.6.32-358.el6.x86_64kdump.img - this file got updated during the yum update on june 23rd.

my other systems which are not yet updated and running 6.4 shows the details as follows, [root@ikm273l ~]# rpm -q kernel kernel-2.6.32-71.el6.x86_64 kernel-2.6.32-358.0.1.el6.x86_64 [root@ikm273l ~]# cd /boot [root@ikm273l boot]# ls -lrt init* -rw-r--r--. 1 root root 13800560 Mar 8 2013 initramfs-2.6.32-71.el6.x86_64.img -rw-r--r--. 1 root root 5748156 Mar 8 2013 initrd-2.6.32-71.el6.x86_64kdump.img -rw-r--r--. 1 root root 16709064 Mar 8 2013 initramfs-2.6.32-358.0.1.el6.x86_64.img -rw-------. 1 root root 5525289 Mar 11 2013 initrd-2.6.32-358.0.1.el6.x86_64kdump.img -rw-r--r--. 1 root root 16778210 Mar 11 2013 initramfs-2.6.32-358.0.1.el6.x86_64_v1.img [root@ikm273l boot]#

Your kernel has not been updated - "kernel-2.6.32-358.el6.x86_64" is the original RHEL 6.4.0 kernel release. Some other package which was updated triggered the rebuild of the 'initramfs' file, but the kernel itself was not updated.

The effect of your command "yum update -x 'kernel*' --skip-broken" had the effect of upgrading the entire system from RHEL 6.4 to RHEL 6.10 _except_ for the kernel and irqbalance packages (the upgrade included all other security patches, bug fixes, and feature enhancements from 2013 to present).

Your other systems have a slightly newer kernel - one bug-fix patch release after the RHEL 6.4.0 release ("kernel-2.6.32-358.0.1.el6" is one minor patch newer than the -358.el6 release). They also have the original RHEL 6.0 kernel (2.6.32-71), so they were likely installed as RHEL 6.0 then updated to 6.4.

Hi James, thanks so much. kindly advise what is to be done here " [root@ikm278l ~]# yum -x 'kernel*' update Loaded plugins: product-id, refresh-packagekit, search-disabled-repos, security, subscription-manager Setting up Update Process rhel-6-server-rpms | 3.5 kB 00:00 rhel-6-server-rpms/primary_db | 65 MB 00:02 Resolving Dependencies --> Running transaction check ---> Package irqbalance.x86_64 2:1.0.4-3.el6 will be updated ---> Package irqbalance.x86_64 2:1.0.7-9.el6 will be an update --> Processing Dependency: kernel >= 2.6.32-358.2.1 for package: 2:irqbalance-1.0.7-9.el6.x86_64 ---> Package microcode_ctl.x86_64 2:1.17-33.26.el6_10 will be updated ---> Package microcode_ctl.x86_64 2:1.17-33.29.el6_10 will be an update --> Finished Dependency Resolution Error: Package: 2:irqbalance-1.0.7-9.el6.x86_64 (rhel-6-server-rpms) Requires: kernel >= 2.6.32-358.2.1 Installed: kernel-2.6.32-358.el6.x86_64 (@anaconda-RedHatEnterpriseLinux-201301301459.x86_64/6.4) kernel = 2.6.32-358.el6 kernel = 2.6.32-358.el6

yum can be configured to try to resolve such errors by temporarily enabling disabled repos and searching for missing dependencies. To enable this functionality please set 'notify_only=0' in /etc/yum/pluginconf.d/search-disabled-repos.conf

Error: Package: 2:irqbalance-1.0.7-9.el6.x86_64 (rhel-6-server-rpms) Requires: kernel >= 2.6.32-358.2.1 Installed: kernel-2.6.32-358.el6.x86_64 (@anaconda-RedHatEnterpriseLinux-201301301459.x86_64/6.4) kernel = 2.6.32-358.el6 kernel = 2.6.32-358.el6 You could try using --skip-broken to work around the problem You could try running: rpm -Va --nofiles --nodigest [root@ikm278l ~]#

The "--skip-broken" option should work here - the "irqbalance" package cannot be upgraded due to the old kernel version which you are apparently required to run. All other packages (except the kernel, due to the 'exclude' setting and 'irqbalance' due to the old kernel version) should be updated.

If you need the new irqbalance version, you could try "yum update kernel-2.6.32-358.2.1.el6 --disableexcludes" to get a slightly newer (but still RHEL 6.4-vintage) kernel, then "yum update" to get the current irqbalance.

Another option would be to simply add 'irqbalance' to the "exclude=" line in yum.conf, so that future "yum update" runs will not required "--skip-broken".