Red Hat Subscription Manager: Mismatched: Linux Workstation

Latest response

Hi there, I have a status mismatched under system purpose, I ran the following command using the --force option and yet, status stays the same, also see attached image:

subscription-manager register --username --password
subscription-manager role --set="Red Hat Enterprise Linux Workstation"
subscription-manager service-level --set="Self-Support"
subscription-manager usage --set="Development/Test"
subscription-manager attach
insights-client --register

Is this a know issue?



So we know you have registered and configured syspurpose values for this system, then attached a subscription (which I am assuming was done via auto-attach, or maybe with a pool), but we need more information to evaluate the mismatch. subscription-manager status should show what the mismatch is, could you provide/evaluate that information? I am hesitant to ask you for more specific information than that here, and it would be best discussed in a support case if possible. Displaying the information related to your attached subscription should also help you determine why: subscription-manager list --consumed.

I suggest that you run "subscription-manager status" to get a report of the reasons for the mismatch, like this...

[root@kvm-02-guest07 ~]# subscription-manager status
   System Status Details
Overall Status: Current

System Purpose Status: Mismatched
- The requested usage preference "Development/Test" is not provided by a currently consumed subscription.
- The service level preference "Self-Support" is not provided by a currently consumed subscription.
- The requested role "Red Hat Enterprise Linux Workstation" is not provided by a currently consumed subscription.

Once you have this report, you can take the corrective action that is right for you. It is likely that you don't have sufficient subscriptions in your account to simultaneously meet all of the system purpose attributes that you are requesting.

Review article for "Troubleshooting System Purpose Mismatches". The --force option will not be helpful in your quest to auto-attach a subscription that matches all of your requested syspurpose attributes. If you had a subscription available in your account that provided all of your system purpose desires and provided your installed product(s), then the steps you executed would have auto-attached a "matching" subscription; but it did not. That means that you should review the "subscription-manager list --available" and decide which of your system purpose constraints are less critical based on the subscriptions you have purchased and then unset them, or maybe you should purchase different subscriptions. There is no one best answer for everyone.


I think one of the key problems here is that there are subscriptions (e.g., my university's "Red Hat Academic Site Subscription with Smart Management...") which do not include any "Roles:" or "Usage:" entries at all, and therefore can never use any "Role" or "Purpose" other than "Not Specified" (or null or blank, depending on the context).

I wasted a lot of time running around in circles with tech support over this, all because nobody at Red Hat could say to me "yeah, your Subscription Manifests don't have any of these defined in them, so just give up and don't use this feature until next year" [or RHEL 9, or whenever they decide to grace us with legit "Roles"]

The end result is that now my Satellite users of RHEL 8 can't tell which of their systems are supposed to be "servers" and which are "workstations" by looking at Satellite, because all of that information is blank (and yes, the distinction still matters - in some areas, desktop/workstation systems are handled differently from servers with regard to patching).

Hi, thanks for the feedback.

I went into the Customer Portal, Systems, selected the system in question, which is only one, I currently use as a workstation on a VM, changed both the Usage Type and Role to Not Specified and System Purpose Status changed to Matched, something is obviously cooking with the subscription system, as I do not have the option after changing that to either change Usage Type or Role, only Not Specified is available. Subscription Management stayed before and after on Properly Subscribed was only the System Purpose. PS., it is a Red Hat Developer Subscription Self-Support so nothing weird

Hi Dirk,

This is a known issue.

Both for Customer Portal registration as well as for RH Satellite registrations.

The only thing that is important that you attached the correct subscription, the System Purpose is not used by Red Hat support or any software currently.


Jan Gerrit

Hi Dirk,

As Jan Gerrit said, it is a known issue ... unset everything excecpt for "Service Level = Self-Support" - then it will show "Matched". :)


With the below settings, it did work, I simply do not like stuff that has a not correct mark alongside it :-) Thanks again for the feedback all in the thread. Subscription Management Properly Subscribed

All installed products are covered by attached subscriptions. Updates can be received through January 19, 2021 07:00.

Subscriptions Attached 1 Auto-Attach Enabled Operating System Release Preference Not Set System Purpose System Purpose Status Matched Service Level Agreement (SLA) Self Support Usage Type Not Specified Role Not Specified

You're welcome, Dirk ! You're not alone ... I also prefer having everything set up properly. :)