RHEL 8.2 registered to RHSM but not receiving updates

Latest response

Hi All,

I am facing a strange issue while getting updates. My timezone is correst along with date and time as IST for today. Its a Virtual Machine

At first I tried to register with company as personal, when it gave error as it doesn't exist and then register with a blank. It still says not registered. When I try again it says already registered but I don't see any green tick or even yum install update doesn't work.

from command line as well tried:

yum repolist all
Updating Subscription Management repositories.
This system is registered to Red Hat Subscription Management, but is not receiving updates. You can use subscription-manager to assign subscriptions.
No repositories available

subscription-manager register --username myid --password mypasswd --auto-attach
This system is already registered. Use --force to override

subscription-manager register --username myid --password mypasswd --auto-attach --force
Unregistering from: subscription.rhsm.redhat.com:443/subscription
The system with UUID xxxxxxxxxxxeef-bfa4-8e9266c28f4f has been unregistered
All local data removed
Registering to: subscription.rhsm.redhat.com:443/subscription
The system has been registered with ID: xxxxxxxxxcf86-479c-a9f8-5xxxxxxxxxxxx
The registered system name is: localhost.localdomain
Installed Product Current Status:
Product Name: Red Hat Enterprise Linux for x86_64
Status: Not Subscribed

Still says not subscribed, when I do yum update it throws the very first error

Also tried this solution:

https://access.redhat.com/discussions/4939071

Still same issue:

[root@localhost ~]# subscription-manager remove --all
0 subscriptions removed at the server.

[root@localhost ~]# subscription-manager attach --auto
Installed Product Current Status:
Product Name: Red Hat Enterprise Linux for x86_64
Status: Not Subscribed

Unable to find available subscriptions for all your installed products.
[root@localhost ~]# subscription-manager status
+-------------------------------------------+
System Status Details
+-------------------------------------------+
Overall Status: Invalid

Red Hat Enterprise Linux for x86_64:
- Not supported by a valid subscription.

System Purpose Status: Not Specified

Responses

Hi Apni,

Check out what I've suggested in the discussion you mentioned ... if it doesn't work contact Customer Service. :)
Additionally check if your subscription is already consumed : sudo subscription-manager list --consumed

Regards,
Christian

Hi Apni,

As a response to what you posted in the other discussion :
Please perform what I have written here - step by step ... :)

Regards,
Christian

Hi Apni,

Yes, you may reach out support team as Christian suggested for a quick help.

Otherwise, please let us know the following command outputs for further assistance (you could mask out confidential details):

# subscription-manager config
OR
# egrep -v '^#|^$' /etc/rhsm/rhsm.conf

Additionally, check out (re-verify) the following :

  • Make sure data/time is correct. I've noticed one such issue where due to incorrect date/time the subscription used to fail.
  • Look out for any errors in the log file '/var/log/rhsm/rhsm.log'.
  • Also, go to https://access.redhat.com/management/ and see if new subscription is active over there.

Hi Sadashiva,

That is the last option, its good to fix here to understand more. Here are the outputs:

[root@localhost ~]# subscription-manager config

[root@localhost ~]# subscription-manager config [server] hostname = [subscription.rhsm.redhat.com] insecure = [0] no_proxy = [] port = [443] prefix = [/subscription] proxy_hostname = [] proxy_password = [] proxy_port = [] proxy_scheme = [http] proxy_user = [] server_timeout = [180] ssl_verify_depth = [3]

[rhsm] auto_enable_yum_plugins = [1] baseurl = [https://cdn.redhat.com] ca_cert_dir = [/etc/rhsm/ca/] consumercertdir = [/etc/pki/consumer] entitlementcertdir = [/etc/pki/entitlement] full_refresh_on_yum = [0] inotify = [1] manage_repos = [1] package_profile_on_trans = [0] pluginconfdir = [/etc/rhsm/pluginconf.d] plugindir = [/usr/share/rhsm-plugins] productcertdir = [/etc/pki/product] repo_ca_cert = /etc/rhsm/ca/redhat-uep.pem repomd_gpg_url = [] report_package_profile = [1]

[rhsmcertd] autoattachinterval = [1440] certcheckinterval = [240] disable = [0] splay = [1]

[rhsmd] processtimeout = [300]

[logging] default_log_level = DEBUG

[] - Default value in use

[root@localhost ~]# egrep -v '^#|^$' /etc/rhsm/rhsm.conf [server] hostname = subscription.rhsm.redhat.com prefix = /subscription port = 443 insecure = 0 ssl_verify_depth = 3 proxy_hostname = proxy_scheme = http proxy_port = proxy_user = proxy_password = no_proxy = [rhsm] baseurl = https://cdn.redhat.com repomd_gpg_url = ca_cert_dir = /etc/rhsm/ca/ repo_ca_cert = %(ca_cert_dir)sredhat-uep.pem productCertDir = /etc/pki/product entitlementCertDir = /etc/pki/entitlement consumerCertDir = /etc/pki/consumer manage_repos = 1 full_refresh_on_yum = 0 report_package_profile = 1 pluginDir = /usr/share/rhsm-plugins pluginConfDir = /etc/rhsm/pluginconf.d auto_enable_yum_plugins = 1 package_profile_on_trans = 0 inotify = 1 [rhsmcertd] certCheckInterval = 240 autoAttachInterval = 1440 splay = 1 disable = 0 [rhsmd] processTimeout = 300 [logging] default_log_level = DEBUG [root@localhost ~]#

Date/time is correct as I also found out that in many tickets. Yes, I do see subscription active and 1 under this virtual machine. I thought it could be for only bare metal but now as I see both options there with 1 active for me, seems something else is the issue.

In subscriptions

it says 1 active with Subscription name as Contract number not available.

When I go to systems:

Subscription Management Not Subscribed

Installed products are not covered by attached subscriptions. Updates cannot be received. I see the same thing here

Hi Apni,

This is definitely an issue related to adding a valid subscription as your system is correctly registered.
Have you tried everything I have written in my article - step by step ? Is there anything shown ? with :

sudo subscription-manager list --available
sudo subscription-manager list --consumed

If not : please do contact the Red Hat Customer Service team ... it is covered by your subscription. :)

Regards,
Christian

Hi Christian,

Yes, I did and posted the output above(I posted in another thread) as well for all the commands: here it is:

Hi Christian,

I tried that again conflicting outputs:

sudo subscription-manager list --consumed No consumed subscription pools were found.

[root@localhost ~]# sudo subscription-manager list --available This system is not yet registered. Try 'subscription-manager register --help' for more information.

However when try from GUI it says already registered, but again out of that page says not register.

Could you or someone please confirm if it works fine on VIrtual Machine? I remember did it in past

Hi Apni,

I already confirmed it in the other thread : "And yes, it works on virtual machines right as it works on physical
machines, no difference.
" Me myself, I have several RHEL systems running in virtual machines ... no issues. :)

Regards,
Christian

Hello Apni,

There is something certainly gone wrong/corrupted with your subscription, as you explained before you had tried multiple registrations. As Christian suggested before, it is best to approach the Customer Service of Red Hat. Yes, subscriptions should work (Server Self Support/Developer Suite...... talk to customer support for more details), which could be used on physical as well virtual systems.

All the best!

ALL !

As two members are facing the exactly same issue at the very same time - I assume there is something wrong on Red Hat's side.
Both members (you Apni, and you, Xiaofeng) : please follow my recommendation and contact the RH Customer Service team. :)

Regards,
Christian

Hi Sadashiva and Christian,

Thanks for your help.

I contacted the customer service as I saw in account it says no pool available assuming something they need to allot. Once sorted out, can I replicate the machine in my lab environment? Shutdown and copy it to make both in cluster or do I need to spin a fresh machine and then register it as the later one is a time consuming task.

You're welcome, Apni ! Hope it gets resolved soon. I would create a new machine, because things like host name,
ip address, machine id should better be different. If you just copy the VM, problems might occur at a later time. :)

Regards,
Christian

What you can do Apni, is create a system disk backup image and clone (restore) it back to a new virtual disk.
There is a tool called clonezilla, that does this job perfectly. Some things like host name have to be changed
afterwards nevertheless. The registering process isn't that time consuming, once the issue is sorted out ... :)

Regards,
Christian

Hi Christian,

Hostname, IP doesn't take that long that I do with my CentOS machines as they don't need registration. Machine ID is the concern when there are apps which need MID. Does, restore from clonezilla reset the machine id or is there any tool like SYSPREP for windows where I can set it to null and whenever my new machine boots up which I copy-paste, it gets a new machine ID.

Hi Apni,

When you clone a disk with clonezilla, a new machine-id gets created automatically by default.
There is an opt-out option if you select advanced mode though, in case you don't want that. :)

Regards,
Christian

its look the certificate is missing.

Confirm from the below command

rct cat-cert /etc/pki/product/69.pem

if you receive a message like The specified certificate file does not exist then you need to generate the new one but make sure to unregister the system first

mkdir -p /etc/pki/product/ restorecon -Rv /etc/pki/product chown root.root /etc/pki/product/69.pem chmod 644 /etc/pki/product/69.pem rct cat-cert /etc/pki/product/69.pem

Register the system again subscription-manager register --auto-attach subscription-manager refresh subscription-manager identity