Failed to download metadata for repo 'rhel-8-for-x86_64-appstream-rpms' Error: Failed to download metadata for repo 'rhel-8-for-x86_64-appstream-rpms'

Latest response

Hi All,

Few hours ago when I do a yum install, it was working. But now I'm trying to execute the below and getting the bellow error details.

[root@installer ~]# yum install -y haproxy
Updating Subscription Management repositories.
Red Hat Enterprise Linux 8 for x86_64 - AppStream (RPMs) 0.0 B/s | 0 B 00:00
Failed to download metadata for repo 'rhel-8-for-x86_64-appstream-rpms'
Error: Failed to download metadata for repo 'rhel-8-for-x86_64-appstream-rpms'

Responses

Hi, Have you tried the solutions in https://access.redhat.com/discussions/4656371?

Or it might only be a temporary issue with RH, I also seen people mention they had this issue but a few hours later it started working without them having done anything specific themselves to resolve it.

Not the same, but I recently had a similar issue which was due our subscription manifest requiring an update.

Regards, Peter

I have tried some of the steps in https://access.redhat.com/discussions/4656371. Incuding sudo dnf clean all sudo rm -r /var/cache/dnf sudo dnf upgrade and subscription-manager register --force. But its not working.

Any extra information from the verbose output which might help point you in the right direction?

yum update -v  ...

Maybe you can then search with some of the additional information you get back.

worked for me after cleaning the /var/cache/dnf/* and re-registering the RHEL 8 client server.

for me today it seems like a non trusted certificate for cdn.redhat.com. Found with dnf upgrade -v.

I made new bug https://bugzilla.redhat.com/show_bug.cgi?id=1908658

I have tried to see if disabling SSL verification works but it didn't had any result.

You can disable rhel-8-for-x86_64-appstream-rpms repo but that is a workaround for in case you don't need RPM''s for the base OS. But it isn't a real solution.

Its because of the entitlement key has expired, this key : etc-pki-entitlement, Update with the latest key in the openshift secrets it will work fine.