Add custom repo to a client

Latest response

Hi,

For testing I've tried to put another repo in my test server.
A content view is already defined for this system and repo available:

]# subscription-manager repos
+----------------------------------------------------------+
    Available Repositories in /etc/yum.repos.d/redhat.repo
+----------------------------------------------------------+
Repo ID:   CentOS_7_CentOS_7_Server_updates
Repo Name: CentOS 7 Server updates
Repo URL:  https://.../development/CentOS_7_Server/custom/CentOS_7/CentOS_7_Ser
           ver_updates
Enabled:   1

Repo ID:   CentOS_7_CentOS_7_Extras
Repo Name: CentOS 7 Extras
Repo URL:  https://.../development/CentOS_7_Server/custom/CentOS_7/CentOS_7_Ext
           ras
Enabled:   1

Repo ID:   CentOS_7_CentOS_7_Tools_6_4
Repo Name: CentOS 7 Tools 6.4
Repo URL:  https://.../development/CentOS_7_Server/custom/CentOS_7/CentOS_7_Too
           ls_6_4
Enabled:   1

Repo ID:   CentOS_7_CentOS_7_subscription_manager
Repo Name: CentOS 7 subscription manager
Repo URL:  https://.../development/CentOS_7_Server/custom/CentOS_7/CentOS_7_sub
           scription_manager
Enabled:   1

Repo ID:   CentOS_7_CentOS_7_Server
Repo Name: CentOS 7 Server
Repo URL:  https://..../development/CentOS_7_Server/custom/CentOS_7/CentOS_7_Ser
           ver
Enabled:   1

I've created a content view and attached it to this client:

# subscription-manager attach --pool=4028a2da708c530b01711204f38e00c9
Successfully attached a subscription for: TheForeman

But I cannot see it with : subscription-manager repos --list or yum repolist

Is this way ok? what could be wrong?
As anyone any ideas?

Thanks in advance

P.S.-: theforeman is already on our RHEL 7 repositories and for this reason I couldn't test on these servers.

Responses

Hi Jérôme,

Please remove the CentOS repositories ... these repositories conflict with the Red Hat ones - and this will lead to a lot of trouble. :)

Regards,
Christian

Hi Christian,

Thanks for your feedback.. I'll do that ;)

Best regards, Jérôme

You're welcome, Jérôme ! :)