VNCserver fails to launch

Posted on

Forgive me if this is in the wrong place, this is my first post! I have been running a RHEL7 server in my office and I needed to reboot said machine for a planned power outage. It came back online without issue, but I cant get my VNCserver to start again! It was working fine before the reboot. It is configured for a single user (The only one who has management authority to login) and I have tried multiple fixes such as:

Resetting the vncpasswd for the user in question
Switching to the user and attempting to start vnc
Removing the files under /tmp/.X11-unix
Tried running under root and also with sudo

The output of systemctl status vncserver@:.service is below (The asterisks are blocking the username, it is in there normally on my system)

[root@fusion /]# systemctl status vncserver@:.service
● vncserver@:.service - Remote desktop service (VNC)
Loaded: loaded (/etc/systemd/system/vncserver@.service; enabled; vendor preset: disabled)
Active: failed (Result: exit-code) since Thu 2020-01-23 10:24:14 EST; 6s ago
Process: 16429 ExecStart=/usr/sbin/runuser -l ******* -c /usr/bin/vncserver %i -geometry 1920x1080 (code=exited, status=2)
Process: 16426 ExecStartPre=/bin/sh -c /usr/bin/vncserver -kill %i > /dev/null 2>&1 || : (code=exited, status=0/SUCCESS)

Jan 23 10:24:13 fusion systemd[1]: Starting Remote desktop service (VNC)...
Jan 23 10:24:14 fusion systemd[1]: vncserver@:.service: control process exited, code=exited status=2
Jan 23 10:24:14 fusion systemd[1]: Failed to start Remote desktop service (VNC).
Jan 23 10:24:14 fusion systemd[1]: Unit vncserver@:.service entered failed state.
Jan 23 10:24:14 fusion systemd[1]: vncserver@:.service failed.