yum install mpich-3.2 not working on 8.1

Latest response

We use mpich 3.2 in our software and have used the yum install mpich-3.2 call in past versions of RHEL, but it will not work in 8 or 8.1. It returns with Error: Unable to find a match: mpich-3.2

Did this change in 8 or is this version no longer available?

Responses

Hi Todd,

Unfortunately the package mpich-3.2 is currently not available for CentOS/RHEL 8 - not in the official and not in external repos. :)

Regards,
Christian

Thank you

You're welcome, Todd ! :)

Hi Todd,

What you can try is to download the package from the RHEL 7 repos and install it manually ... in case no dependency issues occur. :)

Regards,
Christian

It worked for me for RHEL 8.1 today, just now.

I'll post back with what I did

Regards

RJ

Todd,

I was able to load mpich-3.2.1-9.el8.x86_64 with RHEL 8.1 just now. First I built the system, then I added the below repositories, then I added mpich with yum and it resolved two dependancies. I did this prior to the initial yum update. I merely used yum -y install mpich after the first 2 steps I mentioned in this paragraph.

Repos I had enabled:

rhel-8-for-x86_64-supplementary-rpms
satellite-tools-6.6-for-rhel-8-x86_64-rpms
rhel-8-for-x86_64-appstream-rpms
ansible-2.9-for-rhel-8-x86_64-rpms
rhel-8-for-x86_64-baseos-rpms

mpich had two dependancies: tcl and hwloc-libs

mpich came from rhel-8-for-x86_64-appstream-rpms tcl and hwloc-libs came from rhel-8-for-x86_64-baseos-rpms

rpm -q mpich tcl hwloc-libs
mpich-3.2.1-9.el8.x86_64
tcl-8.6.8-2.el8.x86_64
hwloc-libs-1.11.9-3.el8.x86_64

Regards

RJ

Hi RJ,

Thank you for sharing - very same is valid for my setup - installing the package mpich gives us version 3.2.1 :

$ sudo dnf upgrade
Updating Subscription Management repositories.
Red Hat CodeReady Linux Builder for RHEL 8 x86_64 (RPMs)     12 kB/s | 4.5 kB     00:00    
Red Hat Enterprise Linux 8 for x86_64 - AppStream (RPMs)     13 kB/s | 4.5 kB     00:00    
Red Hat Enterprise Linux 8 for x86_64 - BaseOS (RPMs)        14 kB/s | 4.1 kB     00:00    
Red Hat Ansible Engine 2.9 for RHEL 8 x86_64 (RPMs)          11 kB/s | 4.0 kB     00:00    
Dependencies resolved.
Nothing to do.
Complete!

$ sudo dnf list mpich*
Updating Subscription Management repositories.
Last metadata expiration check: 0:00:17 ago on So 12 Jan 2020 12:40:44 CET.
Available Packages
mpich.i686              3.2.1-9.el8       rhel-8-for-x86_64-appstream-rpms
mpich.x86_64            3.2.1-9.el8       rhel-8-for-x86_64-appstream-rpms
mpich-devel.i686        3.2.1-9.el8       rhel-8-for-x86_64-appstream-rpms
mpich-devel.x86_64      3.2.1-9.el8       rhel-8-for-x86_64-appstream-rpms

Because Todd explicitly asked for version 3.2 ("We use mpich 3.2 in our software ..."), I didn't suggest this. :)

Regards,
Christian

Hi Todd,

In case you do NOT explicitly need mpich-3.2 ... you can easily install version 3.2.1 from appstream, the way RJ did and told you. :)

Regards,
Christian

Thanks Christian

Sometimes I forget when someone says they want "3.2" (or some version) - I sometimes forget they really might mean that and I don't always ask if 3.2.1 (or some other available sub-minor release of the software) will work or not.,

Todd, let us know if this works for you or not.

Regards

RJ

Same with me RJ ... me too sometimes forget that someone may for whatever reason rely on a specific version. :)
Anyway, I assume both solutions work, either installing from the 8 repo, or installing the RHEL 7 version manually.

Regards,
Christian

Thank you both fo the info. We will take a look We are specifically needing the 3.2 in the short term.

You're welcome, Todd ! Wish you good luck with testing ... hope version 3.2 from RHEL 7 will work then ... :)

Regards,
Christian

Using the package from 7 seems to have worked. Thanks again for the help!

Hey Todd, that's great news ! Glad we could help you getting it done. :)

Regards,
Christian

Glad to hear.

Regards

RJ