How to get Ansible higher then 2.4.2 in RHEL 7 Jenkins slave

Latest response

Try to get an Ansible version higher 2.4.2 in the base Jenkins slave with a DockerFile:

FROM registry.redhat.io/openshift3/jenkins-slave-base-rhel7
RUN yum-config-manager --enable rhel-server-rhscl-7-rpms && \
    yum-config-manager --enable rhel-7-server-optional-rpms && \
    yum-config-manager --enable rhel-7-server-extras-rpms && \
    yum-config-manager --enable rhel-atomic-host-rpms && \
    yum-config-manager --enable epel && \
    yum-config-manager --enable epel-source && \
    yum-config-manager --enable epel-testing && \
    yum update -y && \
    INSTALL_PKGS="ansible" && \
    yum install -y $INSTALL_PKGS && \
    yum clean all -y

But keeps stuck at Ansible 2.4.2.

I'm aware of the rhel-7-server-ansible-2.8-rpms repo but when using this in the DockerFile I get:

FROM registry.redhat.io/openshift3/jenkins-slave-base-rhel7
RUN yum --disablerepo=* --enablerepo=rhel-7-server-ansible-2.8-rpms install -y ansible
Error getting repository data for rhel-7-server-ansible-2.8-rpms, repository not found

I guess I'm missing something...

Responses

The repository 'rhel-7-server-ansible-2.8-rpms' should be enabled on the host system of Openshift.

See: https://access.redhat.com/articles/3174981