v3.11 install Verify api server is available FAILED

Posted on

I tried to install an openshift 3.11 cluster with 4 centos 7 machine. The error code is above after 120 retries. I tried to check it with

curl --tlsv1.2 --cacert /etc/origin/master/ca-bundle.crt https://master.dev.xxx:443/healthz/ready and really wrong:
curl: (56) Received HTTP code 503 from proxy after CONNECT

I refreshed ansible from redhat git repository.

I tried to check certificate with:

openssl req -text -noout -verify -in /etc/origin/master/ca-bundle.crt

everything seems good.

I tried to install openshift to only one site, but it didn't help

when try to check pods with oc get pods, No resources found, but when I check docker containers I found:

dp | grep api

b10b79f11e68 c8025294fe1d "/bin/bash -c '#!/..." 20 minutes ago Up 20 minutes k8s_api_master-api-xxx_kube_system_5d69d85a51f334a187eeacfd05deb580_0

805d60e2fb91 docker.io/openshift/origin-pod:v3.11.0 "/usr/bin/pod" 20 minutes ago Up 20 minutes k8s_POD_master-api-xxx_kube-system_5d69d85a51f334a187eeacfd05deb580_0

And log of one of these docker containers is empty, but other contains log messages without errors

thx
Zamek