can't install rpm even though repo is enabled

Latest response

Hi, trying to solve this error on RHEL7.7 3.10.0-1062.4.1.el7.x86_64

Error: Package: katello-agent-3.5.1-2.el7sat.noarch (rhel-7-server-satellite-tools-6.5-rpms)
Requires: gofer >= 2.12.5
Installed: gofer-2.12.3-1.el7.noarch (@rhel-7-server-satellite-tools-6.4-rpms)
gofer = 2.12.3-1.el7
Available: gofer-1.3.0-1.el7sat.noarch (rhel-7-server-rh-common-rpms)
gofer = 1.3.0-1.el7sat

I checked repo is enabled and ran
yum repo all
rhel-7-server-satellite-tools-6.5-rpms/x86_64 Red Hat Satellite Tools 6.5 (for RHEL 7 Server) (RPMs) enabled: 11

I ran these, so it makes sense why it fails.
yum --showduplicates list katello
yum --showduplicates list gofer

We run a satellite server on our network and from the GUI i can see
UITS_RHEL (content view) -> rhel-7-server-satellite-tools-6.5-rpms(REPO) -> gofer-2.12.5-3.el7sat.noarch (RPM)

Odd thing is it show 73 rpms not 11 like " yum repo all" says ?

How do i force "yum update" to see the rpm in the enabled repo ?

thank you.
-Angelo

Responses

Hi Angelo,

If i don`t miss undertood, You are trying to update katello-agent but the available version of katello-agent requires a newer version o gofer, that is strange because gofer is available on the same repo. Sometimes yum cache gets lost and we can see some strange behaviors like this.... Try this:

  • yum clean all

  • subscription-manager refresh

And then update katello-agent.

Hi, yes you understood. I got a hold of the Satellite server admin and he fixed on Satellite end. had to sync some REPO i think and then republish a Content View. Then things started working properly on my server. Case Closed.

Great.