Unable to register new server in DMZ.

Latest response

I received a request to build a new external SFTP server for part of my company. We have a new DMZ area we wanted to deploy (network reconfig going on) so the server is the 1st in this area. To save time, I built the server (vmware vm) internally and registered with our Satellite server. Now that is in the DMZ it, of course, can not see the internal Satellite server.

So, I was attempting to point this server to Red Hat for the subscription management and yum repository access.

I modified the
/etc/rhsm/rhsm.conf
and change the hostname to
subscription.rhsm.redhat.com
and the Content Base URL to
https://cdn.redhat.com

When I run the subscription-manager register this is the error I get.

Unregistering from: subscription.rhsm.redhat.com:443/rhsm
Remote server error. Please check the connection details, or see /var/log/rhsm/rhsm.log for more information.

/var/log/rhsm/rhsm.log isn't being helpful really.

I have not tried this before and I may be going about it entirely wrong.

Responses

Hi John,

Before you have changed the rhsm.conf file you should have unregistered the system. Now it tries to reregister the system to RHSM but it is not known so it throwns you an error.

Christiaan