sshd/tcsh do not source .cshrc when executing single command on RHEL8.0

Latest response

I'm observing a change in behavior between 7.x and 8.x installations of RHEL.

When using ssh from a remote host, with key-based authentication, if the user shell is tcsh, the users .cshrc file is not sourced, which causes the command to fail for several environment related reasons (not in PATH, library paths not set, etc.)

If I use ssh -t to allocate a tty on the command the .cshrc is loaded correctly.

I see no options or documentation in release notes about this change in behavior.

If I connect as another user with bash set as the login shell, the environment is sourced as expected. This seems to be a regression in tcsh and behavior does not match the man page for

Anyone else seen this? Have a workaround that doesn't involve setting up /etc/environment or ~/.ssh/environment?


It appears this continues to be an issue in RHEL 8.1.