Failed to synchronize cache for rhel 8 appstream repo

Latest response

After fresh install of rhel 8 with developer subscription
I try run dnf update and i see the following error

Error: Failed to synchronize cache for repo 'rhel-8-for-x86_64-appstream-rpms'

Responses

I try to clean cache but this not work

Hi Jostar,

Execute the following commands :

sudo dnf clean all
sudo rm -r /var/cache/dnf
sudo rm -r /var/cache/PackageKit
sudo dnf upgrade

This should solve the problem ... :)

Regards,
Christian

i tried but this not resolve problem

Hi Jostar,

Unregister and re-register the system and then repeat the procedure being described above. :)

sudo subscription-manager remove --all
sudo subscription-manager unregister
sudo subscription-manager clean

sudo subscription-manager register
sudo subscription-manager refresh
sudo subscription-manager attach --auto

Regards,
Christian

I Tried this and again not resolve problem

Hi Jostar,

Check if the specific repository is enabled and if it is not, enable the AppStream repository. :)

sudo subscription-manager repos --list-enabled
sudo subscription-manager repos --enable rhel-8-for-x86_64-appstream-rpms

Regards,
Christian

Appstream repo enabled This not resolve problem

Repo ID: rhel-8-for-x86_64-appstream-rpms

Repo Name: Red Hat Enterprise Linux 8 for x86_64 - AppStream (RPMs)

Repo URL: https://cdn.redhat.com/content/dist/rhel8/$releasever/x86_64/appstream/os

Enabled: 1

Hi Jostar,

Best would be to contact Red Hat Customer Service then ... such issues are officially supported. :)

Regards,
Christian

A couple others I know of reported this issue as well, but it's resolved itself as of right now. May have been a short lived issue on the CDN.

Hi Tom,

Thanks for chiming in - that's what I wanted to tell Jostar in the first place. What made me wonder though is the
fact that only one repo could not sync. I've tried to reproduce the problem, but in my case everything worked as
expected. That's why I've provided workarounds - maybe the issue occurs only in some regions. Thanks again ! :)

Regards,
Christian