Red Hat EL 8 and amavis

Latest response

Hello everyone,
we installed an EH8 to use as a mail server and for reasons of backward compatibility we decided to use dovecot + sendmail instead of postifix.
we are trying to install an antispam filter on our server but on RH8 it seems we can't install amavisd-new (spamaassassin) because even adding the EPEL repository there are no compatible perl modules, the error message is the following:


Updating Subscription Management repositories.
Ultima verifica della scadenza dei metadati: 0:00:01 fa il ven 13 set 2019 08:56:31 CEST.
Errore:
Problema: conflicting requests
- nothing provides perl(BerkeleyDB) needed by amavisd-new-2.12.0-1.el8.noarch
- nothing provides perl(Digest::SHA1) needed by amavisd-new-2.12.0-1.el8.noarch
- nothing provides perl(IO::Stringy) needed by amavisd-new-2.12.0-1.el8.noarch
- nothing provides perl(MIME::Parser) needed by amavisd-new-2.12.0-1.el8.noarch
- nothing provides perl(MIME::Words) needed by amavisd-new-2.12.0-1.el8.noarch
- nothing provides perl(Convert::TNEF) needed by amavisd-new-2.12.0-1.el8.noarch
- nothing provides perl(File::LibMagic) needed by amavisd-new-2.12.0-1.el8.noarch
- nothing provides perl(MIME::Body) needed by amavisd-new-2.12.0-1.el8.noarch
- nothing provides perl(MIME::Decoder::Base64) needed by amavisd-new-2.12.0-1.el8.noarch
- nothing provides perl(MIME::Decoder::Binary) needed by amavisd-new-2.12.0-1.el8.noarch
- nothing provides perl(MIME::Decoder::Gzip64) needed by amavisd-new-2.12.0-1.el8.noarch
- nothing provides perl(MIME::Decoder::NBit) needed by amavisd-new-2.12.0-1.el8.noarch
- nothing provides perl(MIME::Decoder::QuotedPrint) needed by amavisd-new-2.12.0-1.el8.noarch
- nothing provides perl(MIME::Decoder::UU) needed by amavisd-new-2.12.0-1.el8.noarch
- nothing provides perl(MIME::Entity) needed by amavisd-new-2.12.0-1.el8.noarch
- nothing provides perl(MIME::Head) needed by amavisd-new-2.12.0-1.el8.noarch
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)


has anyone already dealt with it and solved it?

Thank you and greetings

Responses

Enabling codeready-builder repository will for sure help :

subscription-manager repos --enable=codeready-builder-for-rhel-8-x86_64-rpms