CDN Operation too slow

Latest response

Hi,

I'm try install ceph-deploy, calamari-server and calamari-clients but I see error with CDN:

https://cdn.redhat.com/content/dist/rhel/server/7/7Server/x86_64/ceph-installer/1.3/os/repodata/repomd.xml: [Errno 12] Timeout on https://cdn.redhat.com/content/dist/rhel/server/7/7Server/x86_64/ceph-installer/1.3/os/repodata/repomd.xml: (28, 'Operation too slow. Less than 1000 bytes/sec transferred the last 30 seconds')
Trying other mirror.

I checked the internet connection and is ok.

is there some problem with Red Hat CDN?

Regards,
L. Gómez.

Responses

I'm experiencing the exact same issue - starting to regret taking out a subscription for multiple servers.

Hi Luis (and Stuart),

I can confirm the same ... most probably we're facing a temporary issue with the Red Hat servers. Mostly this gets resolved soon. :)

Regards,
Christian

Hi,

same here in Cologne, Germany. I'd really appreciate if this was fixed soon.

Best Regards, Andreas

Hello,

We still have the same issue during 'yum update' ( France ):

https://cdn.redhat.com/content/dist/rhel/server/7/7Server/x86_64/openstack/14/os/Packages/o/os-refresh-config-9.1.2-0.20190420064352.8b84e52.el7ost.noarch.rpm: [Errno 12] Timeout on https://cdn.redhat.com/content/dist/rhel/server/7/7Server/x86_64/openstack/14/os/Packages/o/os-refresh-config-9.1.2-0.20190420064352.8b84e52.el7ost.noarch.rpm: (28, 'Operation too slow. Less than 1000 bytes/sec transferred the last 30 seconds') Trying other mirror. puppet-4.8.2-2.el7ost.noarch.r FAILED
https://cdn.redhat.com/content/dist/rhel/server/7/7Server/x86_64/openstack/14/os/Packages/p/puppet-4.8.2-2.el7ost.noarch.rpm: [Errno 12] Timeout on https://cdn.redhat.com/content/dist/rhel/server/7/7Server/x86_64/openstack/14/os/Packages/p/puppet-4.8.2-2.el7ost.noarch.rpm: (28, 'Operation too slow. Less than 1000 bytes/sec transferred the last 30 seconds') Trying other mirror.

Best regards, Valentina

Same here (USA)

Same here (Brazil)

Same here (France)

Same here (USA)

Seeing this too: Trying other mirror. https://cdn.redhat.com/content/dist/rhel/workstation/6/6Workstation/x86_64/os/Packages/a/abrt-addon-python-2.0.8-44.el6.x86_64.rpm: [Errno 12] Timeout on https://cdn.redhat.com/content/dist/rhel/workstation/6/6Workstation/x86_64/os/Packages/a/abrt-addon-python-2.0.8-44.el6.x86_64.rpm: (28, 'Operation too slow. Less than 1 bytes/sec transfered the last 30 seconds') Trying other mirror. https://cdn.redhat.com/content/dist/rhel/workstation/6/6Workstation/x86_64/os/Packages/a/abrt-cli-2.0.8-44.el6.x86_64.rpm: [Errno 12] Timeout on https://cdn.redhat.com/content/dist/rhel/workstation/6/6Workstation/x86_64/os/Packages/a/abrt-cli-2.0.8-44.el6.x86_64.rpm: (28, 'Operation too slow. Less than 1 bytes/sec transfered the last 30 seconds')

FYI we are investigating some issues customers are reporting of downloading packages. I was having issues sporadically yesterday and today as well. You can monitor the status here:

https://status.redhat.com/

Thank you John for the report. For information, last global cdn-sync took almost 8 hours to run instead of 45 min today. I was able to donwload updates on one server at 9:35PM CET (Paris).

The problem continues.

[MIRROR] pcp-pmda-zswap-4.3.0-4.el8_0.x86_64.rpm: Curl error (28): Timeout was reached for https://cdn.redhat.com/content/dist/rhel8/8/x86_64/appstream/os/Packages/p/pcp-pmda-zswap-4.3.0-4.el8_0.x86_64.rpm [Operation too slow. Less than 1000 bytes/sec transferred the last 30 seconds]

rhel-6-server-extras-rpms still having issues

(6/391): Red_Hat_Enterprise_Linux-Release_Notes-6-en-US-8-2.el6.noarch.rpm | 85 kB 00:00 https://cdn.redhat.com/content/dist/rhel/server/6/6Server/i386/os/Packages/s/SDL-1.2.14-7.el6_7.1.i686.rpm: [Errno 12] Timeout on https://cdn.redhat.com/content/dist/rhel/server/6/6Server/i386/os/Packages/s/SDL-1.2.14-7.el6_7.1.i686.rpm: (28, 'Operation too slow. Less than 1 bytes/sec transfered the last 30 seconds') Trying other mirror.

The same from Ireland

same here in USA IL................ cmon Big Blue

no workarounds out there...??

same here in Finland

only way to get packages VERY slowly is by adding couple of lines to yum.conf minrate=1 timeout=300

As per the status.redhat.com website, the issue is resolved. However, is anyone still facing the issue?

Yep still occurring here for us (USA)

Yes, still the problem (USA).

The same in Ireland, large amount of timeouts on Satellite's pulp when downloading packages, and sync incomplete after that, 'failed to download x packages'

Can also confirm the issue still occurs when accessing the CDN from Cologne, Germany

Experiencing the same problem. Also unable to look at subscriptions in the portal. Spins and/or errors. This problem has been going on for over a day now?

Today two incidents were generated on the status.redhat.com page of which one I see is related to the CDN: Downloads incident. The latest update says:

"Update - We have identified that the performance issues with our downloads is due to a problem with our content delivery network. We will continue to investigate this issue with with our CDN vendor until the issue is identified and resolved."

This can be verified on the page status.redhat.com

Experiencing the same problem, in the Netherlands.

Experiencing a similar issue for the last 2 days in Netherland. If this issue is fixed please update in the comment.

Issue is not fixed, take a look at https://status.redhat.com though updates come through there kind of slowly. Issue is still occurring in the US as it has been for the last three days now.

To all (new) members landing here : It doesn't make much sense to report this (known) issue over and over again ...
Red Hat is aware of the problem and is working on a solution. Please be patient everybody. Thank you very much. :)

Regards,
Christian

And I'd disagree. RH said the issue was fixed yesterday. If people hadn't kept saying 'me too, I continue to have the problem', well, RH may have never known. It may be slightly annoying, but I am not seeing a flood here just a trickle of 'me too's'. Meaning the annoyance level is low for the information that it is.

I share the same opinion.

Hi Paul (and Erinn), alternatively you can also contact the Red Hat Customer Support team. :)

Regards,
Christian

Maybe you're right, Erinn and I do understand what you mean. But please be aware that this is a community discussion portal driven by volunteers and not an official support portal. Such issues
should better be reported by either opening a support case or, by filing a bug report on bugzilla.

Cheers :)
Christian

RH states that they believe the issue has been fixed, but it appears to me at least the issue hasn't been fixed as I continue to get the same issue.

The same, have sync incomplete, many retries and download failures on Satellite

Hi Erinn,

You're right, the issue seems to have returned. It worked as expected for some time, but currently not. The status page for 2019-09-16 says "No incidents reported today". I encourage you to contact Red Hat Customer Service. :)

Regards,
Christian

Our site license does not provide for customer support, so here I am. Someone else can contact customer support, but we don't receive support.

-Erinn

No Erinn - Customer Portal related issues (download/update issues included) are covered
by every subscription (including the free no-cost developer subscription) for all users ... :)

Regards,
Christian

Sorry but you'll have to point me at something that says that. Our contract lists 'RHN Support' as covered, as far as I know RHN is mostly gone at this point, replaced by subscription-manager, but perhaps the terms are being used loosely? I have no idea.

The SLA page states that nothing at all is covered: https://access.redhat.com/support/offerings/production/sla so I generally leave RH support alone unless it is an exceptional circumstance, like when we discover security bugs.

-Erinn

Erinn, as I said : All users who have a valid subscription get support for the mentioned issues.
This includes users with self-support contracts as well. And, they can open support cases for
such issues like this one. Me myself have done this in the past - and I've received support ! :)
Okay, let's stop this - I just wanted to assist you in order to get it resolved "a little bit faster".

Regards,
Christian

Same from Canada

You can see current status (was just changed to Investigating about 2 hours ago) at:

 https://status.redhat.com/

Click the "Subscribe" link, and you can get SMS updates when the status changes.

Yep,...You can include Toronto Canada as well. Had no idea it was so wide spread. Hopefully it will be fixed soon. Redhat usually pushes out yum updates over the internet very quickly.

Please include Bangalore, India as well. Error: https://cdn.redhat.com/content/e4s/rhel/server/7/7.2/x86_64/sap-hana/os/repodata/respond.xml : [Errno 14] HTTPS Error 404 - Not Found Solution tried: Knowledge base article - https://access.redhat.com/solutions/1158093. Also, tried opening a support case however getting same error there as well.

RedHat CDN has issues globally (their provider). Only recourse is to keep an eye on the status page.

The problem is still going on here in Brazil, very inconvinient. Need to get going with the project but this issue is not helping

It seems problem is fixed here in India. I checked just now and able to download updates.

Hey Sayed, I am still facing this issue in India. Please share any workaround for this if you have.

The problem is still going on here in The Netherlands.

The problem is still going on here in Switzerland

Still down in England, UK

Pages