Activating JMX in jboss eap 7.1

Latest response

Hi All,

I'm facing an issue when activating the jmx of jboss, I've already tried including this in domain.xml:

<expose-resolved-model/>
<expose-expression-model/>

Unfortunately the 4447 port that I was expecting is not opened.

Thus I've tried to add the ff in this link: https://access.redhat.com/documentation/en-us/red_hat_jboss_enterprise_application_platform/7.2/html/performance_tuning_guide/monitoring_performance

The setup was reflected in the domain.xml but still port 4447 is not opened..

Thanks!

Responses

Whereas in JB EAP 6, they provided a remoting-connector which, by default, had a socket-binding of 4447 and utilized JMX; in JB EAP 7, it's been superceded by an HTTP protocol variation. Implementations are URL based and configured within the Undertow subsystem. The JBEAP Management system is available over this HTTP as an API with endpoints corresponding to the management resources and attributes to be queried. This overlays on the 'management' http port and is effectively aligned with the jboss-cli commands. Look in the server startup for the Undertow HTTP* Listening port. You'll also need a management-role user account and either access from the localhost or reconfigure to enable public access.