[resolution to] DISCONNECTED install Satellite 6.5.1 fails on Error: Package: foreman-selinux-1.20.0-1.el7sat.noarch Requires: selinux-policy >= 3.13.1-229.el7_6.5

Latest response

Receive selinux-policy dependency errors when performing disconnected Satellite 6.5.1 installation (and possibly upgrade) for

**Hat tip to Thomas Bridle who mentioned his findings/resolution here.

Environment

  • Red Hat Satellite 6.5.1 (as cited here)
  • This issue exists when using RHEL 7.6 and NOT using RHEL 7.7
  • RH Solution ID 3673971 cites this issue, however with different rpm versions

Issue

When attempting to install (or possibly upgrade) Red Hat Satellite in a disconnected environment, you may receive dependency errors regarding the selinux-policy package when running install_packages command from the mounted Satellite ISO:

Error: Package: foreman-selinux-1.20.0-1.el7sat.noarch (satellite-local)
Requires: selinux-policy >= 3.13.1-229.el7_6.5
Installed: selinux-policy-3.13.1-229.el7.noarch (@anaconda/7.6)
The error is repeated for pulp-selinux and candlepin-selinux.

Resolution

Either upgrade the underlying operating system to RHEL 7.7 using a current RHEL ISO or if a new server, build with a RHEL 7.7 Server ISO/DVD. Bottom line, use or upgrade to RHEL 7.7 first.

Component installation installer upgrade Tags install installation satellite upgrade

This is not a Red Hat solution. This is the Red Hat Discussion area. This was written due to the experience cited at the RH Discussion where resolution for this was experienced/cited.

Regards

RJ

Responses

Satellite 6.5.x now supports FIPS from a clean Linux install according to the release notes. I posted a script to automatically install fips with all necessary steps at this location