Nvidia driver failing to install

Latest response

I am trying to install nvidia driver on Precision 7920 running rhel 7.6 kernel 3.10.0-957.21.3.el7.x86_64.

I performed the following steps:
1. Lspci – determine gpu
2. /etc/default/grub
a. GRUB_CMDLINE_LINUX added rdblacklist=nouveau nouveau.modeset=0
3. Grub2-mkconfig -o /boot/efi/EFI/redhat/grub.cfg
4. /etc/modprobe.d
a. Blacklisted nouveau
5. yum install kernel-devel.rpm
6. Set machine to boot into text mode
a. Systemctl get-default
b. Systemctl set-default multi-user.target
c. Systemctl get-default
7. Rebooted

After performing these steps I tried to run the NVIDA driver installer and was given an error of stating that it could not find the kernel path tree.

I specified the kernel-source-path=/lib/modules/3.10.0-957.21.3.el7.x86-64/build/

This still did not recitify the issue.

When I looked at my /lib/modules/kernel/build the link shows as broken.

What am I missing to get this issue resolved? Im at my wits end.

Responses

Anyone know anything? This is still an issue and still cannot load any driver. I have tried current and previous 4 versions. Still the kernel source path is supposedly not found.

Hi Nathan,

Please make sure that kernel-headers are installed as well. :)

Regards,
Christian

Nathan, I was about to type exactly what Christian Labisch wrote above. Give that a shot

Regards

RJ

I just tried to do this and it still fails? is there like a kernel-header rpm that i could try installing? I have the kernel-devel installed.

Hi Nathan,

Execute sudo yum install kernel-headers ... and by the way, I recommend to upgrade to RHEL 7.7 before. :)

Regards,
Christian

I am redownloading my repos. gonna reload them onto the desktop. do a yum clean all and see if it will pull the new repos and see if that works. I will let you know how it goes.

so I yum dated the system from 7.6 to 7.7. I did not have to install the kernel-headers. I was able to install the latest nvidia driver. Thanks christian

Great Nathan, I'm glad you could successfully upgrade to 7.7 and get the NVIDIA drivers installed. :)

Regards,
Christian

Hi Nathan, I am facing issues with nvidia driver installation on a Dell Precision 7530 laptop running RHEL 7.7 I have tried nvidia driver versions 375.6 and 390.48 Can you let me know which version was that you got to running on 7.7?

Hi Nathan, I am facing issues with nvidia driver installation on a Dell Precision 7530 laptop running RHEL 7.7 I have tried nvidia driver versions 375.6 and 390.48 Can you let me know which version was that you got to running on 7.7?

Peter, I was using the 390.4x version at the time it was the latest driver. to get past my error of kernel headers, i had to upgrade from 7.6 to 7.7 due to nvidia not neeing my kernel so when i did the os update to 7.7 it obviously put in the 7.7 kernel and i was then able to boot in and install the driver. I dont know if that was what you were wanting to hear.