OS Upgrade has failed

Latest response

I tried to run an upgrade from RHEL 7 to RHEL 8 (hardware is a tower PC with 4 RAID drives, a 2070 GPU and i7 processor). I followed the instructions here: https://access.redhat.com/documentation/en-us/red_hat_enterprise_linux/8/html-single/upgrading_to_rhel_8/index but the post-leapp reboot led to some odd warnings around wifi and after a system restart I get warnings such as 'failed to find logical memory', 'couldn't get size' before the initial setp-up screen appears. When I then click finish configuration the screen goes black, no other tty are available. I get an occasional flicker from the screen, but nothing else. I have tried removing the graphical interface option and quiet options to see if that helps, but it doesn't. The only non-standard profile element pre-upgrade was nouveau was blacklisted and nvidia drivers were running. Any help would be gratefully received, as I tried to re-install a clean OS from a boot .iso (which I know RH don't really like, but any port in a storm) and I just get dracut-initqueue timeouts.

Responses

Hi Julian,

Did you try to break into the grub menu to go to system target multi-user?

From there try to reinstall the Nvidia driver for your graphics card.

It looks almost like the common issue after a kernel upgrade.

It is still strange that a tty could not be opened.

Regards,

Jan Gerrit Kootstra

Thanks Jan, I'll give this a go.

A hint please hit the ENTER key twice after each end of a sentence, makes the text easier to read.

Ok, will remember that in future

As an update, having left the system just running the display comes back and prints iwlwifi 0000:00:14.3: Unhandled alg: 0x707 which looks to be a network issue, however the machine is plugged into a LAN via RJ45 and not using wifi.... And I do get a VNC Server pop-up appear when I reach the subscription manager page on boot.

It seems a known issue:

https://bugzilla.kernel.org/show_bug.cgi?id=203593

https://devtalk.nvidia.com/default/topic/1039522/jetson-agx-xavier/intel-9260-adapter-not-working/2

are just a few hits.