yum update to ntp.x86_64 v4.2.8p13 not available?

Latest response

We are required to upgrade our NTP to v4.2.8p13.
However, when I issue a
yum update ntp.x86_64

I only get v4.2.6p5-15.el6_10.

Where can I find an RPM for v4.2.8p13?

Responses

Hi SAF

Genuinely curious, are you using RHEL 7? I suspect you are.

I just looked up the most current rpm from the Red Hat downloads area https://access.redhat.com/downloads/content/rhel---7/x86_64/2456/ntp/4.2.6p5-28.el7/x86_64/fd431d51/package and got the below:

Download
Package - ntp-4.2.6p5-28.el7.x86_64.rpm 
SHA-256: 8ed171d73a803347ad801c108db17aeae4269f40aec6add8ca509fa508e80903 
Download Now 
549 KB
Source Package - ntp-4.2.6p5-28.el7.src.rpm 
SHA-256: 61eb37e9bd6dacf2cc7a2d5684e131803f137c1cffcec832460f385e2536a038 
Download Now 
4.14 MB
Debug Info Package - ntp-debuginfo-4.2.6p5-28.el7.x86_64.rpm 
SHA-256: 35b5a81c12df62fcc1fe642737e7c1bcee01e6d92f3b608222f6c24d71398f88 
Download Now 
1.7 MB

Is there any chance the version you are looking to acquire is for the upstream version (non-Red Hat)? The most current rpm is listed above (according to the Red Hat RPM search in the link I provided above).

What happens when you run the following (enter the root account first)

yum clean all
yum repolist
echo n | yum update
echo n | yum update ntp

I have a Red Hat Linux system directly connected to Red Hat and the ntp version is "ntp-4.2.6p5-28.el7.x86_64". I ran yumdownloader ntp and got the same version of ntp-4.2.6p5-28.el7.x86_64.rpm

Red Hat uses something called backporting https://access.redhat.com/solutions/57665 which may affect the expectation of the difference of the upstream open source version of an rpm against the latest version Red Hat provides.

Regards

RJ

Thank you for your digging, and your response!

Actually, we're on RHEL 6.

Yes, it is possible that the Red Hat repositories do not yet have the NTP version we're looking for. Before assuming that's the case, I wanted to be sure.

Per your suggestion, I went ahead with the yum clean all; yum repolist and tried again. Still yum says there's no available ntp package beyond my current version: 4.2.6p5-15.el6_10.

SAF,

I'm glad you got it sorted...

Thanks for using the discussion forums, and welcome,

Regards

RJ

SAF

I should have picked up (and I missed) you are using RHEL 6.10 (it's in the rpm name you originally provided). You certainly are on the most current rpm of ntp according to this RPM search https://access.redhat.com/downloads/content/rhel---6/x86_64/168/ntp/4.2.6p5-15.el6_10/x86_64/fd431d51/package

Download
Package - ntp-4.2.6p5-15.el6_10.x86_64.rpm
SHA-256: 742c7bebe5ff01ece97121f65b417c4d45163e14b612426a08a82f4bd2fe2cc6
600 KB

The yum commands you used validated it

Regards

RJ