[VR] RHEL 8 Not detecting USB's or External Drives.

Latest response

Hello
After I setup my RHEL 8 fresh install I ran 'yum update' and some 224 updates were installed. I rebooted the system. For restoring my backed-up data, when I connect my External Hard-drive It's not detecting. I tried rebooting the system again. I tried different ports. I tried different Drives including USB's. But no use. When I run 'lsblk' no external device is being shown, but when I run 'dmesg' I can find my WD External Hard-drive. (Image attached)
Can You please help me fixing this? I'm a newbie and so curious about these kinda errors and stuff...

Thank You.lsblk and dmesg

lsmod

Responses

Hi Venkat,

Does lsmod show USB drivers?

Regards,

Jan Gerrit

Yes Sir 'lsmod' shows the external drive. Sorry for the late reply. Thank You.

Can you post the output of lsmod | grep -i usb

Maybe another forum member does notice an issue.

Done! Included in the post.

I do not see an issue.

Maybe you should open a support case?

Sir, I've solved it temporarily. Like when I made the update, it created a new entry of OS in GRUB. I booted into the old one Instead of new one. And external devices work in old entry.
Thank You for your time in diagnosing the issue.