Mistake in documentation to upgrade from Satellite 6.2 to Satellite 6.3

Latest response

In the preparation steps for the Satellite 6.2 to Satellite 6.3 there is a mention for what repositories should be enabled. It seems to me there is a mistake in it.
It states:
Ensure only the required repositories are enabled.

subscription-manager repos --disable=*

subscription-manager repos \

--enable=rhel-7-server-rpms \
--enable=rhel-server-rhscl-7-rpms \
--enable=rhel-7-server-satellite-maintenance-6-rpms \
--enable=rhel-7-server-satellite-6.2-rpms

What I think it should be:
Ensure only the required repositories are enabled.

subscription-manager repos --disable=*

subscription-manager repos \

--enable=rhel-7-server-rpms \
--enable=rhel-server-rhscl-7-rpms \
--enable=rhel-7-server-satellite-maintenance-6-rpms \
--enable=rhel-7-server-satellite-6.3-rpms

Responses

Hello Ward,

This seems a correct assumption to me.

Please open a support ticket for the product "Customer Portal" current version to get this corrected by the Tech Writers.

Regards,

Jan Gerrit Kootstra

Hello,

are you referring to 2.3.4. Migrating a Satellite Server? That section is not the upgrading section, in that context "migrating" is moving from a RHEL6 to a RHEL7 server.

Upgrading comes later in 2.4.1. Upgrading a Connected Satellite Server where the foreman-maintain tool will set up the repos for you.

Hi Stephen,

You are right about me looking in a wrong section of the documentation.

All's well that ends well. Thanks for confirming.