Unablt to Join Rhel VM to Domain

Latest response

Hi All,
Need you expertise as after I've unjoined a VM to the Domain, im having hard time joining it back, Im getting error as below, Already have taken the following troubleshooting listed, I also tried to create a new Red Hat VM, and join it to the Domain but getting the same issue.

  1. Change Hostname/IP of the VM
  2. Delete the AD Object / Rejoin to the Domain
  3. Created New VM but got the same error
  4. Used 2 different Domain Admin Account
  5. Date/Time are correct
  6. the Rhel VM can see the DNS/DC servers

Nov 21 04:34:57 vm.localdomain realmd[1946]: Failed to join domain: Failed to set machine spn: Operations error
Nov 21 04:34:57 vm.localdomain realmd[1946]: Do you have sufficient permissions to create machine accounts?
Nov 21 04:34:57 vm.localdomain realmd[1946]: ! Joining the domain fintrax.com failed

Responses

Hi Gerard,

I assume the system clocks on AD server and your VM are in sync.

And that you already verified that the SPN is unique (no identical hostname exist in any subbdomain)?

Can you post the verbose version of the command you tried to execute. Something like:

# realm join -v fintrax.com --computer-ou OU=...,OU=... -U ad-adm-user

Regards,

Dusan Baljevic (amateur radio VK2COT)

Close

Welcome! Check out the Getting Started with Red Hat page for quick tours and guides for common tasks.