Error running atomic-openshift-installer

Latest response

Hi all, I've gone through all the prerequisites here - https://docs.openshift.com/enterprise/3.0/install_config/install/prerequisites.html#system-requirements to setup 2 VM's. This is just an evaluation, so I only have 2 nodes defined.

Once I completed the prerequisite instructions, I provided a ~/.config/openshift/installer.cfg.yml file, and then ran:

atomic-openshift-installer -u install

Unfortunately, I only ever get the following. Does anybody have a suggestion?

2018-11-29 09:37:12,698 p=14468 u=root |  TASK [openshift_facts : Gather Cluster facts and set is_containerized if needed] **********************************************************************************************************************************************************************
2018-11-29 09:37:13,897 p=14468 u=root |  fatal: [10.166.4.141]: FAILED! => {"changed": false, "module_stderr": "KeyError('ansible_os_family',)\nTraceback (most recent call last):\n  File \"/root/.ansible/tmp/ansible-tmp-1543505832.74-69576155005289/AnsiballZ_openshift_facts.py\", line 113, in <module>\n    _ansiballz_main()\n  File \"/root/.ansible/tmp/ansible-tmp-1543505832.74-69576155005289/AnsiballZ_openshift_facts.py\", line 105, in _ansiballz_main\n    invoke_module(zipped_mod, temp_path, ANSIBALLZ_PARAMS)\n  File \"/root/.ansible/tmp/ansible-tmp-1543505832.74-69576155005289/AnsiballZ_openshift_facts.py\", line 48, in invoke_module\n    imp.load_module('__main__', mod, module, MOD_DESC)\n  File \"/tmp/ansible_openshift_facts_payload_tJ1pWF/__main__.py\", line 2101, in <module>\n  File \"/tmp/ansible_openshift_facts_payload_tJ1pWF/__main__.py\", line 2082, in main\n  File \"/tmp/ansible_openshift_facts_payload_tJ1pWF/__main__.py\", line 1579, in __init__\n  File \"/tmp/ansible_openshift_facts_payload_tJ1pWF/__main__.py\", line 1613, in generate_facts\n  File \"/tmp/ansible_openshift_facts_payload_tJ1pWF/__main__.py\", line 1836, in init_provider_facts\n  File \"/tmp/ansible_openshift_facts_payload_tJ1pWF/__main__.py\", line 1784, in guess_host_provider\nNameError: global name 'get_file_content' is not defined\n", "module_stdout": "", "msg": "MODULE FAILURE\nSee stdout/stderr for the exact error", "rc": 1}

thanks!

Responses

I was facing the same issue while installing openshift-3.9, I solved it, by manually copying the ssh-key for the root into the /root/.ssh/authorized_keys and then restarting the sshd restart. I see that you are using root user to install, so you would need to copy the /root/.ssh/id_rsa.pub into the /root/.ssh/authorized_keys Also ensure that if you have non-root user, passwordless sudo is needed. The error was related to the ssh-key.

For details, Please do follow: https://docs.openshift.com/container-platform/3.9/install_config/install/host_preparation.html

Thanks for your comment. I had already setup passwordless ssh between the VMs. In my case, I ended up moving to 3.2, but - I still hit the same issue. I then proceeded to downgrade my Ansible to 2.3.2, and that solved the issue. Now I have "FAILED - RETRYING: Wait for Node Registration" 50 times :) ... but at least it's a different issue. From what I've read, this one may be due to certificates. I don't think it's DNS related as I setup a DNS server already.

Close

Welcome! Check out the Getting Started with Red Hat page for quick tours and guides for common tasks.