Stuck on 'Starting dracut initqueue hook' ... on RHEL 7.5 Kickstart installation

Latest response

I am creating a dev kickstart.iso based on dvd.iso from RHEL 7.5 version but the installation is stuck on the below message and nothing is happening.

[OK] Started Open -iSCSI.
Starting dracut initqueue hook....

Below is the Kickstart label on my isolinux.cfg

label kickstart
menu label ^Kickstart 7.5
menu default
kernel vmlinuz
append ks=cdrom:/ks.cfg inst.stage2=hd:LABEL=RHEL-7.5\x20Server.x86_64 initrd=initrd.img xdriver=vesa nomodeset biosdevname=0 quiet

Grub.cfg contains the following
set default="1"

function load_video {
insmod efi_gop
insmod efi_uga
insmod video_bochs
insmod video_cirrus
insmod all_video
}

load_video
set gfxpayload=keep
insmod gzio
insmod part_gpt
insmod ext2

set timeout=60

END /etc/grub.d/00_header

search --no-floppy --set=root -l 'RHEL-7.5 Server.x86_64'

BEGIN /etc/grub.d/10_linux

menuentry 'Install Red Hat Enterprise Linux 7.5' --class fedora --class gnu-linux --class gnu --class os {
linuxefi /images/pxeboot/vmlinuz inst.stage2=hd:LABEL=RHEL-7.5\x20Server.x86_64 quiet
initrdefi /images/pxeboot/initrd.img
}
menuentry 'Test this media & install Red Hat Enterprise Linux 7.5' --class fedora --class gnu-linux --class gnu --class os {
linuxefi /images/pxeboot/vmlinuz inst.stage2=hd:LABEL=RHEL-7.5\x20Server.x86_64 rd.live.check quiet
initrdefi /images/pxeboot/initrd.img
}
submenu 'Troubleshooting -->' {
menuentry 'Install Red Hat Enterprise Linux 7.5 in basic graphics mode' --class fedora --class gnu-linux --class gnu --class os {
linuxefi /images/pxeboot/vmlinuz inst.stage2=hd:LABEL=RHEL-7.5\x20Server.x86_64 xdriver=vesa nomodeset quiet
initrdefi /images/pxeboot/initrd.img
}
menuentry 'Rescue a Red Hat Enterprise Linux system' --class fedora --class gnu-linux --class gnu --class os {
linuxefi /images/pxeboot/vmlinuz inst.stage2=hd:LABEL=RHEL-7.5\x20Server.x86_64 rescue quiet
initrdefi /images/pxeboot/initrd.img
}
}

Responses

Thanks Sadashiva. I will check this out to see if this resolves my problem.

Hi Sadashiva, It seems that I am no longer getting stuck in Starting dracut initqueue hook. However, during installation mode in gui, I click on verify for the installation source (Auto Detected installation media Device sr0 label RHEL-7.5_Server.x86_64) and I got this pop-up message window "The media is not good to install from".

On the mkisofs command, I added the this -V "RHEL-7.5 Server.x86_64" (the full script command below)

mkisofs -o kickstart7.5.iso -b isolinux/isolinux.bin -c isolinux/boot.cat -no-emul-boot -boot-load-size 4 -boot-info-table -R -J -V "RHEL-7.5 Server.x86_64" -T .

Is the "RHEL-7.5 Server.x86_64" parameters correct for rhel 7.5? Is there anything I missed for parameters?

I just had to change the pxe info to match the disk name. Also, the pxe menu I setup had wrong info wrt ip address and interface names. Instead of giving static ip address, used dhcp to provision ip address. This fixed the issue for me

I had a similar problem with a much stupider reason -- the virtual console was started with scroll lock enabled, this also keeps the server from booting :)