custom repositories missing from subscription-manager repos --list

Latest response

Hi!

I have a satellite6 server with several RH repos and a few custom repos. In my content view I have enabled both, but when running
subscription-manager repos --list the custom ones does not show up at all. I have tried both via a external capsule and directly from Satellite without sucess. Do I have to perform any further steps to make those repos show up in subscription-manager?

Thanks,

Erling

Responses

Erling,

Thank you for starting this discussion. Can you provide a list of the steps you have followed so far?

The repositories available to a host are determined by the host's Content View and Environment. Verify both of these in the Satellite web UI by navigating to Hosts > Content Hosts. If you believe those values are correct, the next step would be to confirm the repositories contained by the Content View. In the Satellite web UI navigate to Content > Content Views and click on the name of the specific Content View. Click Yum Content menu item > Repositories. The result is a list of the Yum repositories available in the specific Content View.

This was a user error :) I assumed that subscription assignment was something only relevant to Red Hat repositories, so I did not realize that Satellite automatically generated subscriptions for the custom channels. The solution was simply to assign subscriptions for the custom channels to all servers and update the activation keys to assign subscriptions to new servers automatically.

sorry to open this thread up again.. I still have custom repositories from not showing up.. I have some nagios repos setup via a product page and they are uptodate. Have subscribed from both command line and webui and enabled it even thru override yes. After I register the system thru activation key that includes base os repos, i manually subscribe to these addtnl repos . On doing --consumed it shows up that subscription is consumed for the custom repo but yum repo does not show that and have tried doing subscriptiion manager refresh, refreshing the subscription manifest ,unregistering and registering back. any thoughts what Iam missing ?

Hi,

I had the same problem. 1. if your server is registered to Satellite tied to specific content view, you have to go to that content view -> yum repositories -> add that repo 2. Once you added, stay there, and under Versions, you have to Push the New version. Otherwise, you wont be able to see it as repo on your client machine

Mine worked once I pushed the view version. Once you do that you can enable the repo on your client.

Hope this helps

Thanks to Erling for solution when I made the same user error. If the docs I used to create the product had that step I wouldn't have needed to google it.

All,

The steps to perform:

  1. add the custom product subscription to server that need them via WebUI or hammer.
  2. subscription-manager refresh
  3. subscription-manager repos --enable custom product repositories
  4. yum clean all
  5. yum install custom packages

If this fails:

subscription-manager re-register with changed activation key --force

Regards,

Jan Gerrit Kootstra