gdm black screen after upgrade from 7.3 to 7.4

Latest response

Greetings, I have tried twice to upgrade from 7.3 to 7.4 using yum.

The gdm gnome login screen was fine, and after the upgrade it launches to a black screen.

I've tried various things through forums, shortening the gdm banner length, checking the pam.d settings, setting gdm debug=true and restarting. I can't find anything out of the ordinary in the /var/log/messages, x, or gdm logs.

The only thing listed in messages is "gdm started", but no other lines associated with the gdm process.

I thought that something might have gone awry with the install since x was running the first time I tried it. I reinstalled the backup image, verified it worked, disabled the gdm.service booted into a console and reran the yum update. Same results after I reenabled the service and restarted gdm.

X appears to be working fine, kicked it old school by creating an .xinitrc with the line "exec gnome-session" and gnome launched fine.

If anybody has some advice or ideas, please feel free to send them on. I'm stumped and have hit the end of my troubleshooting ability with this.

Thank you!

Michael Kmetz's picture

Responses

Hi Michael,

You mention you checked pam.d settings, but still, have you seen gdm fails to start with blank screen in Red Hat Enterprise Linux 7?

Hi Michael,

Just my two cents ... the jump from GNOME 3.14 to version 3.22 is not a trivial thing - this is why I recommend a clean installation. :)

Regards,
Christian

FWIW, I upgraded (using both yum update and the GUI tool) a number of machines without any issues. So, I would encourage users to try upgrading first and only consider a clean install if the upgrade fails.

Hi Robert,

I think it depends on the individual setup ... I have tested the upgrade and it failed because a lot of dependency issues were reported. I agree with you, when an upgrade works flawlessly, there is no need to perform a clean installation, but when it doesn't work as it should a clean install takes less time than fixing the mess. I know, this topic is a bit opinion based - some prefer this, others that. :)

Regards,
Christian

Hello Robert, thank you. I did see that post. Last Friday, I took at the leading dash to see if it would generate any additional logs and it did. I am getting a:

polkitd unregistered authentication agent for unix process objectpath org freedesktop

So far, my searching on this has lead to mixed results as some people say it's benign. I am continuing to work on it.

Christian, thank you as well. It would be nice to do a clean installation, however it will be impossible with our production machines and I need to figure out how to do it on our testbed.

Again, thank you both for your help and responses. I will continue to post if I stumble across anything.

Hi Michael,

You're welcome ! :)
I can understand your situation and I wish you good luck with your attempts to getting all problems sorted out.

Regards,
Christian

I got the same problem after yum updating to 'vmlinuz-3.10.0-693.11.1.el7.x86_64'. The workaround is to go back to my older kernel by booting to 'vmlinuz-3.10.0-514.26.2.el7.x86_64'

Was this helpful?

We appreciate your feedback. Leave a comment if you would like to provide more detail.
It looks like we have some work to do. Leave a comment to let us know how we could improve.
Close

Welcome! Check out the Getting Started with Red Hat page for quick tours and guides for common tasks.