Modifying screensaver timeout

Latest response

I have an environment where some analysts use a RHEL 7 Workstation through a VDI desktop - i.e. from their Windows desktop, they connect to a RHEV user portal and login to their RHEL VDI desktops.

The default screen lock appears to kick in at about 5 minutes, which is way too short. We need at least 15 minutes, and there is also a display monitor where the screensaver should never kick in.

According to some articles I found in a google search, I created two files in /etc/dconf/db/local.d - 00-screensaver and 00-session and set them as below:

00-screensaver
[org/gnome/desktop/session]
# Set the lock time out to 900 seconds before the session is considered idle
idle-delay=uint32 900
[org/gnome/desktop/screensaver]
# Set this to true to lock the screen when the screensaver activates
lock-enabled=false
# Set the lock timeout to 900 seconds after the screensaver has been activated
lock-delay=uint32 900

00-session
[org/gnome/desktop/session]
idle-delay=uint32 900

Unless I've made a typo above is there anywhere else this parameter should be set?

Paul

Responses

Did you found it?

That seems correct - kbase reference here -> https://access.redhat.com/solutions/1201153

Close

Welcome! Check out the Getting Started with Red Hat page for quick tours and guides for common tasks.