Red Hat Enterprise Linux 6.6 boot problem

Latest response

Hi

I have recently updated my Red Hat Enterprise Linux system through the Red Hat Network, and today I was trying to reboot my system, but the booting process somehow hanged at the following screen:

...
Starting sshd: [OK]
Starting ntpd: [OK]
Starting postfix: [OK]
Starting crond: [OK]
Starting atd: [OK]
Starting Red Hat Network Darmon: [OK]

Then it just hanged here and cannot enter into the usual GUI login in screen. However, I can log into the same computer from my laptop through ssh at this stage.

I also found the following information from /var/log/Xorg.0.log:

#

[ 22.722] Initializing built-in extension XFree86-DRI
[ 22.722] Initializing built-in extension DRI2
[ 22.722] (II) LoadModule: "glx"
[ 22.724] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[ 22.786] (II) Module glx: vendor="NVIDIA Corporation"
[ 22.786] compiled for 4.0.2, module version = 1.0.0
[ 22.786] Module class: X.Org Server Extension
[ 22.786] (II) NVIDIA GLX Module 310.19 Thu Nov 8 01:12:43 PST 2012
[ 22.786] Loading extension GLX
[ 22.786] (II) LoadModule: "nvidia"
[ 22.786] (II) Loading /usr/lib64/xorg/modules/drivers/nvidia_drv.so
[ 22.793] (II) Module nvidia: vendor="NVIDIA Corporation"
[ 22.793] compiled for 4.0.2, module version = 1.0.0
[ 22.793] Module class: X.Org Video Driver
[ 22.793] ================ WARNING WARNING WARNING WARNING ================
[ 22.793] This server has a video driver ABI version of 15.0 that is not
supported by this NVIDIA driver. Please check
http://www.nvidia.com/ for driver updates or downgrade to an X
server with a supported driver ABI.
[ 22.793] =================================================================
[ 22.793] (EE) NVIDIA: Use the -ignoreABI option to override this check.
[ 22.793] (II) UnloadModule: "nvidia"
[ 22.793] (II) Unloading nvidia
[ 22.793] (EE) Failed to load module "nvidia" (module requirement mismatch, 0)
[ 22.793] (EE) No drivers available.
[ 22.793] (EE)
Fatal server error:
[ 22.793] (EE) no screens found(EE)
[ 22.793] (EE)
Please consult the Red Hat, Inc. support
at https://www.redhat.com/apps/support/
for help.
[ 22.793] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[ 22.793] (EE)

#

Can you tell me what could be wrong with my system?

Many thanks!

Jon

Sanliang Ling's picture

Responses

Hello Jon,
Did you install the proprietary Nvidia drivers? If so, did you use akmod-nvidia/kmod-nvidia - or did you use the Nvidia installer?

Can you press CTRL-ALT-F2 at that point to give you another console?

Anyhow - it seems as though it is attempting to start the Xserver and failing. Likely due to the driver. I have not, personally, needed to use the Nvidia driver for my systems in a while, but I am also not that discerning regarding video performance on my Linux desktops ;-)

Here a few links:
https://access.redhat.com/discussions/497283
https://access.redhat.com/solutions/64300
https://access.redhat.com/discussions/757803

Hi

Thanks a lot for the information. Indeed, it seems to be a nvidia driver issue, possibly due to the incompatible nvidia driver with the recently updated Linux kernel and Xorg driver. I have manually updated the nvidia driver on my workstation and the booting is fine now.

Thanks again for the help.

Jon

I highly recommend use of ELRepo's kmod-nvidia [1]. First run nvidia-detect [2] to identify the driver package that supports your Nvidia card. Once installed, the Nvidia driver survives kernel update transparently. It also disables nouveau for you.

[1] http://elrepo.org/tiki/kmod-nvidia
[2] http://elrepo.org/tiki/nvidia-detect

I agree with this recommendation. If I need to use the nvidia video driver, I opt to use the akmod-nvidia driver as it manages all the "busy work" of having that 3rd-party driver and modules.

"An akmod is a type of package similar to dkms. As you start your computer, the akmod system will check if there are any missing kmods and if so, rebuild a new kmod for you. Akmods have more overhead than regular kmod packages as they require a few development tools such as gcc and automake in order to be able to build new kmods locally."

Yup, I've used that as well in the past, makes sense and works well.

Close

Welcome! Check out the Getting Started with Red Hat page for quick tours and guides for common tasks.